Felmeddelande vid Pygame Zero installation

av Uppdaterad 2023-01-10

Det kan dyka upp ett felmeddelande när man försöker installera Pygame Zero med en senare version av Python (3.11). För att lösa detta kan vi installera Python 3.10.

Installera och skapa projekt med Python 3.10

  1. Ladda ner Python 3.10 från pythons hemsida, Python.org.
    – Direktlänk till Python 3.10 till windows här:
    https://www.python.org/ftp/python/3.10.9/python-3.10.9-amd64.exe
    – Direktlänk till Python 3.10 till Mac här: https://www.python.org/ftp/python/3.10.9/python-3.10.9-macos11.pkg
  2. Installera filen som du laddat ner
    3. Starta PyCharm
    4. Skapa ett nytt projekt i PyCharm och tryck på den lilla pilen bredvid ”Project Interpreter: New Virtualenv Environment” (se bild nedan)

5. I rullistan bredvid ”Base Interpreter”, välj en tidigare version av Python, t.ex. Python 3.10. Det kan se lite olika ut här beroende på vilken dator man sitter på (se bild nedan). På Windows står det t.ex. 310 istället för 3.10.

6. Tryck på Create (glöm inte att också ge projektet ett namn)
7. Installera Pygame Zero i projektet enligt instruktionerna i kursen

Unga Programmerare håller kurser i programmering för barn och ungdomar. Unga Programmerare startades av studenter från Chalmers Tekniska Högskola.

Företagsinfo

Innovation Institute of Sweden AB
Box 2062, 116 74 Stockholm
Org.nr. 559290-7603

Följ oss

Nyhetsbrev